Blog Archives

Heartbleed Bug – Change Your Online Passwords Now


Revisions:
4/11/2014: Initial release.


This last week there has been an encryption flaw identified inside the Open SSL protocol that is used in many popular websites today that can affect you. See the excerpt below from the main heartbleed.com website:


The Heartbleed Bug is a serious vulnerability in the popular OpenSSL cryptographic software library. This weakness allows stealing the information protected, under normal conditions, by the SSL/TLS encryption used to secure the Internet. SSL/TLS provides communication security and privacy over the Internet for applications such as web, email, instant messaging (IM) and some virtual private networks (VPNs).

The Heartbleed bug allows anyone on the Internet to read the memory of the systems protected by the vulnerable versions of the OpenSSL software. This compromises the secret keys used to identify the service providers and to encrypt the traffic, the names and passwords of the users and the actual content. This allows attackers to eavesdrop on communications, steal data directly from the services and users and to impersonate services and users.

So what are some example sites? Well, this is what I’m going to be doing this weekend, changing passwords for a lot of my accounts at sites like:

  • Facebook
  • Twitter
  • Gmail
  • Yahoo
  • Flickr
  • Youtube
  • Dropbox
  • Box

and a few more.

Thankfully, banking websites or sites like amazon or ebay were not compromised. To learn more about the bug, and other sites that have or have not patched their servers, see the links below.

I am advising anyone who reads this article to change your passwords as soon as possible. You do not want to be part of identity theft or worse. It will become a living nightmare.

Heartbleed Site

Mashable